Opened 10 years ago

Closed 9 years ago

#151 closed defect (fixed)

Unable to spoof source MAC address on OS X

Reported by: aturner Owned by: aturner
Priority: low Milestone: 3.2.2
Component: tcpreplay Version: 3.0.RC1
Keywords: Cc:
Operating System: Add to FAQ?: yes
Hardware: All
Output of tcpreplay -V:

Description

This is related to ticket #142. Basically you have the choice of:

  1. Spoofing source MAC address and limiting your ethernet frame to 1500 bytes
  2. Not spoofing the source MAC address and being able to send full sized 1514 byte frames

This only seems to affect OS X. The default is #2, but you can force option #1 by specifying --enable-force-inject to configure.

Unfortunately, this is a kernel bug not a bug in tcpreplay, so I'm waiting for Apple to release a fix (as of 10.4.9).

Change History (3)

comment:1 Changed 9 years ago by aturner

  • Milestone changed from Future Release to 3.3
  • Status changed from new to assigned

comment:2 Changed 9 years ago by aturner

  • Milestone changed from 3.3 to 3.2.2

comment:3 Changed 9 years ago by aturner

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [1930]) enable src mac spoofing on OS X now that Leopard fixes issue w/ spoofing and
large frames. fixes #142, #151

Note: See TracTickets for help on using tickets.